Pixel Buds Bug Fixes Now Include People Just Turning Off Features

Share on facebook
Share on twitter
Share on linkedin
Share on reddit

When the new Pixel Buds arrived last year, the sales pitch from Google certainly got me. The thought of a pair of true wireless buds with a focus on comfort and appearance in addition to sound and smarts was exactly what I was looking for. In my review, I made it clear that these were the buds I enjoyed the most, at least at the time.

Fast forward to today and the general story of the Pixel Buds doesn’t echo my early impressions and has since turned to an unpleasant one for many. After my review, the Buds landed in the ears of countless others and the reports of issues piled up so quickly that Google had to lay out a multi-month roadmap for updates that would address each and every one.

Google tried to address audio cutouts, hissing sounds, and other connectivity issues through those updates. Whether or not any of that was fixed depends on your pair of Pixel Buds or ears, I think. The Google Support community for the Pixel Buds 2 and the Google Pixel subreddit are filled with folks who continue to have problems with their expensive true wireless buds and/or have discovered what they believe to be fixes for whatever the bug of the day is.

As an example, a month or so ago I ran into an issue where my left Pixel Bud had completely drained and didn’t seem to want to charge. The right bud was fully charged and ready to rock, but nothing, even a factory reset on the Buds, could get the left to work. And then I discovered a thread with hundreds of responses from people experiencing the same issue dating back to May of last year. Their solution? After factory resetting, you had to pair and immediately turn off in-ear detection. If you accomplished that move, the left ear bud would then magically charge again and start working. I’m not kidding. It worked.

In another post I noticed this morning, some Pixel Buds owners were talking about how a long-running audio imbalance issue can be fixed simply by turning off the Adaptive Sound option in the Pixel Buds app. I’m not sure that everyone has found this to fix their problems, but you get the point. People invested $180 into Google’s new Pixel Buds and have run into so many issues since owning them that they’ll try anything.

What started out as a pair of wireless earbuds that ticked every single box has turned into an ongoing headache for those who bought in. I can’t even count the number of comments I’ve read over the months where Pixel Buds owners say they’ve given up hope and talked Google into refunding their purchase.

It’s too bad, man, because the Pixel Buds are still about the most comfortable ear buds I own and have without question the best touchpad and control system of any buds. But when your $180 ear buds are struggling in ways they were a year ago and you attempt to fix them on your own by turning off some of their best features, maybe these aren’t the play.

Via: droid-life.com

Share with friends:

Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn
Share on reddit
Reddit